Strategic CIO // Executive Insights & Innovation
Commentary
9/28/2007
02:48 PM
Alexander Wolfe
Alexander Wolfe
Commentary
Connect Directly
Twitter
Facebook
RSS
E-Mail
50%
50%

Driver Problems Prove Windows Vista Still Isn't Fully Baked

I'm a music guy, and enjoy listening to tunes on my PC. So when the high-definition audio all of a sudden stopped working on my Vista machine, it was a big problem. Unfortunately, my investigation found that my issue was just o

I'm a music guy, and enjoy listening to tunes on my PC. So when the high-definition audio all of a sudden stopped working on my Vista machine, it was a big problem. Unfortunately, my investigation found that my issue was just one small drop in a sea of Windows Vista driver problems, which still haven't been corrected--a full nine months after the formal launch of the operating system.Let's take my specific audio difficulties first. High-definition audio is a spec developed by Intel, which is implemented on most of the newer motherboards. Thus, it's likely you'll have it on your Vista PC; not because the box has Vista, but because by definition it's a machine of recent vintage.

You might think it's odd that I'm so concerned about high-def audio, when I don't even take full advantage of its features. The spec, which replaced the earlier AC '97 PC standard, is notable because of its Dolby 5.1 capabilities. However, all I've got is a decent but not-too-fancy set of Boston Acoustics computer speakers. They're stereo, with a separate woofer. (Please don't call a dinky computer speaker a "sub-woofer." Where I come from that'd be a 15-inch speaker in a wood enclosure with its own 100-W amp, preferably tube.). My point is that I use the PC's high-def audio not because I'm high-def, but because it's the default audio on the machine and it's built into the motherboard.

OK, enough nattering. Here's the problem sequence:

  • Audio started off working fine.

    My box has a 3.2-GHz, dual-core Pentium D 940 processor, Intel D945PVS motherboard, and Windows Vista Ultimate as its OS. I forget exactly when I put the machine together, but I'm been running Vista on it since Microsoft released it in January. The audio was working fine, until the . . . .

  • Audio stopped working all of a sudden.

    Last month, there came a day when the music died. According to the audio properties box, the high-def audio was no longer connected. Windows Device Manager saw the high-def codec. It just wasn't working.

    Several attempts to reinstall the driver, and to uninstall and re-attach (i.e., "scan for new hardware") the codec and the audio devices came to naught.

    Finally, in desperation, I fished an old Creative Labs audio card out of the junk bin and installed it. This revived the audio, but of course I couldn't let it alone, both because I wanted to find out the cause of the problem, and because who wants a $20 audio card on a fancy new dual-core Vista machine?

  • I investigated the Vista forums.

    Here's where it gets interesting. In searching for the root of the problem, I came across numerous other cases where people had exactly the same difficulties I'd encountered. That's correct: high-definition audio crapping out is a widespread issue for Vista users. Interestingly, it turns out that this is not necessarily Microsoft's fault. More on that later.

    The problems seem to exist regardless of whether your system has the SigmaTel high-definition codec, like mine does, or the Realtek codec. (There also are discussions here and here.)

    All the forum traffic advises the same thing: find the most current driver. It'd be nice if fixing the problem was that simple. It isn't.

  • I attempted to fix the problem.

    My first attempt at restarting my audio was to grab the most current SigmaTel driver and install it. (Note that SigmaTel's drivers aren't available from IDT -- the company which makes the codec -- but instead have to be obtained from the maker of your motherboard. In my case, this was Intel.) I downloaded the 5.10.5511.0 driver from Intel. I then banged my head against the virtual wall through several unsuccessful rounds of uninstall-restart-install-restart.

    One thing that really annoys me about all this stuff is, it may be trivial to do driver installs in terms of the brain power which is required, but it sure sucks up a lot of valuable time. I really resent being forced to do stuff that should have been taken care of on the vendor end.

    At this point, it hadn't yet hit me that the most current driver, certified and supplied by my motherboard vendor -- and Intel to boot -- might not be the solution. Thus, I figured the problem had to lie elsewhere.

    Accordingly, I went into Vista to look for its list of installed Windows Updates. These are patches which Microsoft pushes down to your machine (automatically, if you're not careful). In the case of Vista, there have been many patches over the past nine months. Most of them involve security, but some touch Windows Media Center, digital-rights-management, and software licensing.

    My thought was that one of the updates might have messed with the SigmaTel driver, and was therefore at fault. However, rolling back all non-security patches after the date at which the audio went out didn't correct the problem.

    In retrospect, I don't know why I thought it would. If you've got a bad driver, you've got a bad driver. A system restore would have made more sense. But, like an airplane pilot caught in a storm, one's clear thinking often goes out the window in the midst of debugging a Windows problem.

  • Finally, a fix.

    Eventually, it dawned on me that Vista itself wasn't at fault. I believe it's likely that Vista at some point updated the SigmaTel driver, and put a non-working (though certified) driver in place of the one that was originally on my system. However, Vista itself was not balking on the audio front. The codec simply "wanted" another driver.

    As I mentioned, SigmaTel, which is now owned by IDT, doesn't source its drivers. Intel, which made my D945PVS motherboard, only offered that useless 5.10.5511.0 driver.

    I turned up another source of SigmaTel drivers at Softpedia. As reluctant as I was to download them from this non-vendor source, I figured it was a better bet than that .ru Web site -- that's a Russian domain -- which also had SigmaTel drivers.

    I tried two SigmaTel drivers. The 6.10.5290 driver worked, and my high-definition audio was back in business.

    Aftermath

    While it's the job of a blogger to universalize from his or her own experience, it wouldn't be fair to suggest that my travails alone meant there was a problem with Vista drivers. However, when you add that to all the threads I saw on The Vista Forums and on the TechNet Vista Forums (these are two separate and distinct online discussion venues), then you've got ample evidence.

    So, yes, Virginia, there's a problem with Vista drivers. I'm not just talking audio drivers, but graphics drivers, USB drivers, and wireless card drivers, too (among others).

    As I mentioned earlier, the blame for absent of not-quite-ready-for-prime-time drivers can't be laid entirely at Microsoft's door. That's because most of the drivers don't come from Microsoft, but from third parties (i.e., the vendors who make the audio codecs and graphics cards.)

    However, the lengthy delays in getting Vista to market clearly have something to do with the fact that Vista drivers are still being buzzed out. Eventually, and probably very soon, all these issues will disappear as the recalcitrant drivers are replaced by working ones.

    For now, though, this is a situation which didn't have to -- and shouldn't have -- come to pass.

    Comment  | 
    Print  | 
    More Insights
  • The Business of Going Digital
    The Business of Going Digital
    Digital business isn't about changing code; it's about changing what legacy sales, distribution, customer service, and product groups do in the new digital age. It's about bringing big data analytics, mobile, social, marketing automation, cloud computing, and the app economy together to launch new products and services. We're seeing new titles in this digital revolution, new responsibilities, new business models, and major shifts in technology spending.
    Register for InformationWeek Newsletters
    White Papers
    Current Issue
    InformationWeek Tech Digest September 23, 2014
    Intrigued by the concept of a converged infrastructure but worry you lack the expertise to DIY? Dell, HP, IBM, VMware, and other vendors want to help.
    Flash Poll
    Video
    Slideshows
    Twitter Feed
    InformationWeek Radio
    Sponsored Live Streaming Video
    Everything You've Been Told About Mobility Is Wrong
    Attend this video symposium with Sean Wisdom, Global Director of Mobility Solutions, and learn about how you can harness powerful new products to mobilize your business potential.