Microsoft Steers Firefox Users Wrong On XP SP1

Some customers running Windows XP Service Pack 2 and Firefox are being incorrectly told that their PCs must be upgraded.



Microsoft, which will end support of Windows XP SP1 in less than two weeks, incorrectly flags users running Mozilla's Firefox browser that they need to update when they visit the Windows Web site.

The Redmond, Wash. developer has warned users of the four-year-old Windows XP Service Pack 1 (SP1) several times that it will stop all support for the operating system Oct.10, the next regularly-scheduled patch date. It has repeatedly recommended that users update to Windows XP SP2, which can be downloaded free of charge from the company's Web site.

On that Web site, however, users running Windows XP SP2 and Firefox are incorrectly told that their PCs must be upgraded. Internet Explorer users, on the other hand, are given the correct information.

"Your computer is not up to date with the latest version of Windows XP. Upgrade to Windows XP Service Pack 2 (SP2) today to help keep your computer secure," the site tells Firefox users.

IE users, however, are shown a different message: "Your computer has already been upgraded to Windows XP Service Pack 2 (SP2)."

After the Oct. 10 security updates, Microsoft will no longer distribute fixes to Windows XP SP1 users, including any meant to patch IE 6 SP1, the browser edition included with the pack. In addition, Windows XP SP1 users will not be able to update to the more secure IE 7 when that releases in final form later this year.

We welcome your comments on this topic on our social media channels, or [contact us directly] with questions about the site.
Comment  | 
Email This  | 
Print  | 
RSS
More Insights
Copyright © 2020 UBM Electronics, A UBM company, All rights reserved. Privacy Policy | Terms of Service